dlubal.api.rfem.Application#

The dlubal.api.rfem.Application represent API client for interacting with RFEM 6.

It enables you to manage models, work with model objects, and perform calculations—including retrieving results—programmatically, offering greater efficiency, automation, and flexibility in your workflows.

Quick Start

The following example demonstrates how to quickly get started with the RFEM API client by initializing the client and creating a new model.

from dlubal.api import rfem

# Initialize and connect to RFEM
with rfem.Application(api_key_value="your_api_key") as rfem_app:
    # Retrieve application info
    app_info = rfem_app.get_application_info()
    print("Application Info:", app_info)

    # Create a new model
    rfem_app.create_model(name="QuickStart_Model")
    print("Model created successfully.")

Constructor#

Application([api_key_value, api_key_name, ...])

General#

Application.get_application_info()

Returns information about the application

Application.close_application()

Closes the whole application

Application.close_connection()

Closes connection to Webservice server

Model#

Application.create_model(*, name[, ...])

Creates new model with the name specified in request.

Application.open_model(*, path)

Opens model from path specified in 'name' field of the request Returns model id of opened model

Application.save_model(*[, model_id, path])

Saves model specified by model id to optional specified path

Application.close_model(*[, model_id])

Closes model specified by model id

Application.close_all_models(*, save_changes)

Closes all open models

Application.get_active_model()

Returns model id of an active model

Application.set_active_model(*, model_id)

Sets active model specified by model id

Application.get_model_list()

Returns list of models and information about them

Application.get_model_main_parameters(*[, ...])

Retrieves the main parameters of a model, including its ID, name, description, comments, file path, and associated project details.

Objects#

Application.create_object(obj[, model_id])

Creates a single object in the model.

Application.create_object_list(objs[, ...])

Creates a list of objects in the model.

Application.update_object(obj[, model_id])

Updates a single object in the model.

Application.update_object_list(objs[, model_id])

Updates a list of objects in the model.

Application.delete_object(obj[, model_id])

Deletes a single object from the model.

Application.delete_object_list(objs[, model_id])

Deletes a list of objects from the model.

Application.delete_all_objects(*[, ...])

Deletes all objects

Calculation#

Application.calculate_all(*, skip_warnings)

Performs a full calculation for all objects.

Results#

Application.get_results(results_id[, filters])

GetResults returns Table, which is just a convenience wrapper around a Pandas Dataframe.

Tools#

Application.plausibility_check(*, type, ...)

Performs validation based on the specified validation type.