dlubal.api.rfem#
This section documents the object types provided by the dlubal.api.rfem
subpackages.
These objects are used to define and manipulate RFEM models through the gRPC API.
# Import the rfem subpackage
from dlubal.api import rfem
# Create a Node object from the structure_core module
node = rfem.structure_core.Node(
no=1, # Node identifier
coordinate_1=3.0 # X-coordinate of the node
)
# Send the Node object via gRPC to interact with the RFEM server
- rfem.structure_core
- rfem.structure_advanced
- rfem.base_data
- rfem.building_model
- rfem.calculation_diagrams
- rfem.concrete_design_objects
- rfem.construction_stages
- rfem.dynamic_loads
- rfem.geotechnical_analysis
- rfem.global_parameters
- rfem.guide_objects
- rfem.imperfections
- rfem.loading
- Action
- ActionCombination
- CombinationWizard
- DesignSituation
- LoadCase
- LoadCombination
- ModalAnalysisSettings
- OptimizationSettings
- PushoverAnalysisSettings
- RelationshipBetweenLoadCases
- ResultCombination
- SpectralAnalysisSettings
- StabilityAnalysisSettings
- StaticAnalysisSettings
- WindSimulationAnalysisSettings
- rfem.loads
- rfem.results
- rfem.load_wizards
- rfem.result_objects
- rfem.aluminum_design_objects
- rfem.steel_design_objects
- rfem.timber_design_objects
- rfem.types_for_aluminum_design
- rfem.types_for_concrete_design
- rfem.types_for_lines
- rfem.types_for_members
- rfem.types_for_nodes
- rfem.types_for_solids
- rfem.types_for_special_objects
- rfem.types_for_steel_design
- rfem.types_for_surfaces
- rfem.types_for_timber_design