create_model#

dlubal.api.rfem.Application.create_model(self, *, name: str, template_path: str | None = None) ModelId#

Creates new model with the name specified in request. Returns model id of created model

Parameters:
  • name (str) – Name of the new model

  • template_path (str | None) – Path to the existing template to be opened

Returns:

dlubal.api.common.model_id_pb2.ModelId

See also

  • ModelId — More details about the ModelId object.


Example

from dlubal.api import rfem

with rfem.Application() as rfem_app:
    rfem_app.create_model(name='new_model')