calculate_all#

dlubal.api.rfem.Application.calculate_all(self, *, skip_warnings: bool, model_id: ModelId | None = None) OperationResult#

Performs a full calculation for all objects. Returns result of the operation, description of the result and possibly additional information about an error.

Parameters:
  • skip_warnings (bool) – Specifies whether to skip warnings during the calculation.

  • model_id (dlubal.api.common.model_id_pb2.ModelId | None) – Unique identifier of the model.

Active model is used if this field is not set.

Returns:

dlubal.api.rfem.application_pb2.OperationResult

Calculates all load cases, combinations, and add-ons.


Example

from dlubal.api import rfem

with rfem.Application() as rfem_app:
    rfem_app.open_model("model_path")
    rfem_app.calculate_all(skip_warnings=True)