get_object#

dlubal.api.rfem.Application.get_object(self, obj, model_id: ModelId | None = None)#

Retrieves a single object from the model using only the no argument in the object arguments.

Parameters:
  • obj (obj) – An object to be retrieved defined by its number. Refer to the dlubal.api.rfem for available objects.

  • model_id (ModelId | None) – Unique identifier of the model.

Returns:

A retrieved object.

Return type:

dlubal.api.rfem

# Saving the return object into variable
node_1 = rfem_client.get_object(rfem.structure_core.Node(no=1))

Tip

The object definition for the get_object() function only requires the object number.