open_model#

dlubal.api.rfem.Application.open_model(self, *, path: str) ModelId#

Opens model from path specified in ‘name’ field of the request Returns model id of opened model

Parameters:

path (str) – Path to the existing model to be opened

Returns:

dlubal.api.common.model_id_pb2.ModelId

my_model_path = r"C:\Users\my\Desktop\cantilever.rf6"
my_modlel_id = rfem_app.open_model(path=my_model_path)