plausibility_check#

dlubal.api.rfem.Application.plausibility_check(self, *, type: <google.protobuf.internal.enum_type_wrapper.EnumTypeWrapper object at 0x7eabcbea6240>, skip_warnings: bool, model_id: ~dlubal.api.common.model_id_pb2.ModelId | None = None) OperationResult#

Performs validation based on the specified validation type. Returns result of the operation, description of the result and possibly additional information about an error.

Parameters:
  • type (dlubal.api.rfem.application_pb2.PlausibilityCheckType) – Specifies various validation checks that can be performed before generating a mesh, running a calculation, or verifying plausibility.

  • skip_warnings (bool) – Specifies whether to skip warnings during the calculation.

  • model_id (dlubal.api.common.model_id_pb2.ModelId | None) – Unique identifier of the model.

Active model is used if this field is not set.

Returns:

dlubal.api.rfem.application_pb2.OperationResult


Example

rfem_app.plausibility_check()