get_model_main_parameters#

dlubal.api.rfem.Application.get_model_main_parameters(self, *, optional_model_id: ~dlubal.api.common.model_id_pb2.OptionalModelId =) ModelMainParameters#

Retrieves the main parameters of a model, including its ID, name, description, comments, file path, and associated project details.

Parameters:

optional_model_id (dlubal.api.common.model_id_pb2.OptionalModelId)

Returns:

dlubal.api.rfem.application_pb2.ModelMainParameters


Example

model_main_param = rfem_app.get_model_main_parameters()
print(model_main_param)

Output:

model_id: "e26df371-250b-48b4-8a2e-e548d1cadb4c"
model_name: "cantilever"
model_path: "D:/_GIT/API_Webservice_II/python/examples/rfem/cantilever.rf6"