delete_object_list#

dlubal.api.rfem.Application.delete_object_list(self, objs: list, model_id: ModelId | None = None)#

Deletes a list of objects from the model.

Parameters:
  • objs (list[obj]) – A list of objects to be deleted. Refer to the dlubal.api.rfem for available objects.

  • model_id (ModelId | None) – Unique identifier of the model.

Returns:

None


Example

# Delete a list of objects; only the object number is needed in the object arguments.
rfem_app.delete_object_list(
    [
        rfem.structure_core.Material(no=1),
        rfem.structure_core.Material(no=2),
    ]
)

Tip

The object definition for the delete_object_list function only requires the object number.