get_object_id_list#

Deprecated since version 2.10.1: This method is no longer necessary as prerequsity to retrieve model objects. Please use the extended get_object_list() directly.

dlubal.api.rfem.Application.get_object_id_list(self, *, object_type: EnumTypeWrapper | None = None, parent_no: int | None = None, model_id: ModelId | None = None) ObjectIdList#

Retrieves object ids filtered by a specific type. If you want to retrieve all object ids, do not specify the object_type.

Parameters:
  • object_type (dlubal.api.rfem.object_type_pb2.ObjectType | None) – The type of objects to retrieve. To get all object ids, omit it.

  • parent_no (int | None) – Unique identifier of the parent object.

Omit this parameter if the object type does not have a parent or you want to get result for all parent objects.

model_id (dlubal.api.common.model_id_pb2.ModelId | None): Unique identifier of the model.

If not specified, the active model is used.

Returns:

dlubal.api.rfem.application_pb2.ObjectIdList

Example usage:

rfem_app.get_object_id_list()

Output:

object_id {
no: 1
object_type: OBJECT_TYPE_MATERIAL
}
object_id {
no: 1
object_type: OBJECT_TYPE_SECTION
}
object_id {
no: 1
object_type: OBJECT_TYPE_NODE
}
object_id {
no: 2
object_type: OBJECT_TYPE_NODE
}
object_id {
no: 1
object_type: OBJECT_TYPE_LINE
}
object_id {
no: 1
object_type: OBJECT_TYPE_MEMBER
}