get_object_list#

dlubal.api.rfem.Application.get_object_list(self, objs: list, model_id: ModelId | None = None)#

Retrieves a list of objects from the model.

Parameters:
  • objs (list[obj]) – An object list to be retrieved. Refer to the dlubal.api.rfem for available objects.

  • model_id (ModelId | None) – Unique identifier of the model.

Returns:

A list of retrieved objects.

Return type:

dlubal.api.rfem


Example

# Create an object of type Material in the active model
rfem_app.get_object_list()


# Get all objects from specific type without parent
all_members = rfem_app.get_object_list([rfem.structure_core.Member()])


# Get all objects from specific type with parent
all_member_load = rfem_app.get_object_list([rfem.loads.MemberLoad(load_case = '')])


# Get all objects
all_objects = rfem_app.get_object_list([rfem.All()])