delete_object#

dlubal.api.rfem.Application.delete_object(self, obj, model_id: ModelId | None = None)#

Deletes a single object from the model.

Parameters:
  • obj (obj) – An object to be deleted defined by its number. Refer to the dlubal.api.rfem for available objects.

  • model_id (ModelId | None) – Unique identifier of the model.

Returns:

None


Example

# Delete an object of type Material; only the object number is needed in the object arguments.
rfem_app.delete_object(rfem.structure_core.Material(no=1))

Tip

The object definition for the delete_object function only requires the object number.