update_object#

dlubal.api.rfem.Application.update_object(self, obj, model_id: ModelId | None = None)#

Updates a single object in the model.

Parameters:
  • obj (obj) – An object to be updated. Refer to the dlubal.api.rfem for available objects.

  • model_id (ModelId | None) – Unique identifier of the model.

Returns:

None

# Updating coordinates of Node No. 1
rfem_app.update_object(rfem.structure_core.Node(no=1, coordinate_1=1, coordinate_2=5))