Application#

Application.__init__(api_key_value=None, api_key_name=None, url='127.0.0.1', port='9000', ssl=False, ssl_file='')#

Initialize the RFEM client and connect to gRPC server.

Parameters:
  • api_key_value (str, optional) – Value of the API key. It can be found in Extranet under My Data. Every API key starts with ‘ak’ (default is None).

  • api_key_name (str, optional) – Name of the API key stored or to be stored. Can be any string of letters and numbers starting with ‘ak’, 51 characters long.

  • url (str, optional) – URL number.

  • port (int, optional) – Port number.

  • ssl (bool, optional) – False if NOT using SSL auth. True if using the installed version of SSL certificate, or path to .crt certificate if using a file.

  • ssl_file (str, optional) – Path to SSL certificate file (.crt, .pem).


Example

from dlubal.api import rfem

with rfem.Application() as rfem_app:

Tip

Using python’s scope manager ‘with’ keeps your code more organized.